Don’t Google ‘Google’ and don’t name a CRM org “Portals”

I am putting together a fresh development virtual machine image running CRM 2016 for my developer team.  I also wanted to install and configure ADXStudio Portals as we are planning more projects using this technology.

I setup Dynamics CRM 2016 and named my default organization “TEST”.  Brought up CRM with no issues.  I decided to deploy another clean CRM org and called it “PORTAL”, as this was going to be the clean CRM organization with Portals loaded.

deployment
Deployment Manager

 

When I browsed to the organization, I got a weird error:

error
Error when viewing CRM

 

So I investigated the error log, and found a weird compilation error:

Exception message: c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\web.config(389): error CS0234: The type or namespace name ‘Linq’ does not exist in the namespace ‘System’ (are you missing an assembly reference?)

errorlog

That was really weird.  Thanks to some Googling (YEAH!  I use GOOGLE, not BING, get over it!), I stumbled upon this KB article from Microsoft:

https://support.microsoft.com/en-gb/kb/3084967

mystery
Microsoft KB 3084967

 

So apparently “PORTAL” is an organization name that will cause issues.

So I created a new org called “ADXDEV” and all was well.

I hope this info helps someone out!

Cheers
Nick

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s